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Typographic Conventions 
 

Type Style Description 

Example text Words or characters that appear on the screen. These include field 
names, screen titles, pushbuttons as well as menu names, paths and 
options. 

Cross-references to other documentation. 
Example text Emphasized words or phrases in body text, titles of graphics and 

tables. 

EXAMPLE TEXT Names of elements in the system. These include report names, 
program names, transaction codes, table names, and individual key 
words of a programming language, when surrounded by body text, for 
example, SELECT and INCLUDE. 

Example text Screen output. This includes file and directory names and their paths, 
messages, source code, names of variables and parameters as well 
as names of installation, upgrade and database tools. 

EXAMPLE TEXT Keys on the keyboard, for example, function keys (such as F2) or the 
ENTER key.  

Example text Exact user entry. These are words or characters that you enter in the 
system exactly as they appear in the documentation.  

<Example text> Variable user entry. Pointed brackets indicate that you replace these 
words and characters with appropriate entries. 
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Query Print Layout  

Introduction 
The User Reports function enables SAP Business One users to establish a link between a saved 
user-defined query and a print layout.  

As in regular documents and reports, you can use the Print Layout Designer to design the print 
layout for each user-defined query, for example by changing the font type, font size, report borders 
and limits, or calculating sub-totals.  

 
Changes made in the user-defined query will not affect its linked print layout. In order for 
such changes to become effective in the print layout, you have to link the respective print 
layout with the updated query. 

Creating Print Layouts for User-Defined Queries 

Procedure 
1. To create a print layout for user-defined queries, choose Tools → Queries → Query Print Layout 

from the menu bar.  

The Query Print Layout… window appears. 

 
 

As a default, the system creates one print layout for every new company. This print layout is 
called User Report (System). 
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2. To create additional print layouts for your user reports, double-click this default print layout to 
open the Print Layout Designer.  

3. Make any required changes and save the layout under a new name. 

 

Result 
The new print layout for user reports will be added to the Query Print Layout… window on the 
Templates tab page. 

 

 
Since your new print layout is not linked to a specific user-defined query, you can change 
layout elements such as the font, color, header data etc. This however, will not have any 
effect on the query’s content. 
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Linking Print Layouts to User-Defined Queries 

Use 
You can link a user-defined query to a print layout for user reports. 

Prerequisites 
You have created a query using the Query Generator or the Query Wizard.  

Procedure 

1. To open the Queries Manager, choose  with the quick info text Queries Manager from the 
toolbar. 

The Queries Manager window appears. 

 
2. Select the required query and choose Create Report. 
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The Create User Report window appears. 

 

The query name will be automatically displayed in the field Name. If necessary, you can change 
this name manually. 

3. Choose the required base template (print layout) according to which you would like to print your 
query and then choose OK. 

4. After you link a query to a print layout, to modify the design to use it as a report template, 
choose Tools → Queries → Query Print Layout from the menu bar. 

 

The Query Print Layout… window appears. On the Reports tab page you can see all user 
queries that are linked to user report templates. 

5. Double-click a query name to open the Print Layout Designer window. 

6. Make the required changes and save the print layout. 
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You can create several print layouts for the same query by saving the linked print layout 
under different names. 

 

Printing User-Defined Queries 

Use 
After you have linked a user-defined query to a user report template, you can print it according to its 
linked print layout. 

Procedure 
To print a user-defined query, use one of the following two procedures: 

Using the Query Print Layout window: 
... 

1. Choose Tools → Queries → Query Print Layout.  

2. Choose the Reports tab page and select the query you would like to print. 

3. Choose File → Print.  

The user-defined query is printed according to its linked print layout. 
 

Using the Queries Manager window: 
... 

1. From the toolbar, choose  with the quick info text Queries Manager. 

2. Select the query you would like to print. 

3. Choose File → Print. 

The user-defined query is printed according to its linked print layout. 
 

 
You can also display a print preview for user-defined queries. To do so, choose File → 
Print Preview. 

 

© SAP AG 2005 8  



SAP Business One 2005 How to Create Query Print Layouts    

Printing User-Defined Queries with Variables 

Use 
When a user-defined query contains variables, its linked print layout will also display the variables 
data and print them. 

Example 
A user-defined query contains the condition: WHERE CardCode = [%0]: 

 

In the print layout linked to that query, you can see that an additional area containing the condition's 
parameters was added: 
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When you print this user-defined query, the parameters selected for the query will be printed at the 
beginning of the query: 
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Copyright 
 

© Copyright 2005 SAP AG. All rights reserved. 
 

No part of this publication may be reproduced or transmitted in any form or for any purpose without the express 
permission of SAP AG. The information contained herein may be changed without prior notice. 

Some software products marketed by SAP AG and its distributors contain proprietary software components of 
other software vendors. 

Microsoft, Windows, Outlook, and PowerPoint are registered trademarks of Microsoft Corporation.  

IBM, DB2, DB2 Universal Database, OS/2, Parallel Sysplex, MVS/ESA, AIX, S/390, AS/400, OS/390, OS/400, 
iSeries, pSeries, xSeries, zSeries, z/OS, AFP, Intelligent Miner, WebSphere, Netfinity, Tivoli, and Informix are 
trademarks or registered trademarks of IBM Corporation in the United States and/or other countries.  

ORACLE® is a registered trademark of ORACLE Corporation. 

UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group. 

Citrix, ICA, Program Neighborhood, MetaFrame, WinFrame, VideoFrame, and MultiWin are trademarks or 
registered trademarks of Citrix Systems, Inc.  

HTML, XML, XHTML and W3C are trademarks or registered trademarks of W3C®, World Wide Web 
Consortium, Massachusetts Institute of Technology.  

JAVA® is a registered trademark of Sun Microsystems, Inc.  

JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented 
and implemented by Netscape.  

MaxDB is a trademark of MySQL AB, Sweden.   

SAP, R/3, mySAP, mySAP.com, xApps, xApp, and other SAP products and services mentioned herein as well 
as their respective logos are trademarks or registered trademarks of SAP AG in Germany and in several other 
countries all over the world. All other product and service names mentioned are the trademarks of their 
respective companies. Data contained in this document serves informational purposes only. National product 
specifications may vary.  

These materials are subject to change without notice. These materials are provided by SAP AG and its affiliated 
companies ("SAP Group") for informational purposes only, without representation or warranty of any kind, and 
SAP Group shall not be liable for errors or omissions with respect to the materials. The only warranties for SAP 
Group products and services are those that are set forth in the express warranty statements accompanying 
such products and services, if any. Nothing herein should be construed as constituting an additional warranty. 

SQL Server® is a registered trademark of Microsoft Corporation. 

WinFax® is a U.S. registered Trademark from Symantec Corporation. 

Sybase and SYBASE (logo) are trademarks of Sybase, Inc. 

Intel and Intel JPEG Library are trademarks of Intel, Inc. 

SEE4C (SMTP/POP3 Email Engine Library for C/C++) is the copyright of - MarshallSoft Computing, Inc. 

Victor Image Processing Library and VIC32 are trademarks of Catenary Systems. The Victor Image Processing 
Library is copyright material. This includes the source code, object code, dlls, examples, and documentation. 
This material is protected by United States copyright law as well as international copyright treaty provisions. 

THE APACHE SOFTWARE LICENSE, VERSION 1.1 

Copyright (c) 1999 The Apache Software Foundation.  All rights reserved. Redistribution and use in source and 
binary forms, with or without modification, are permitted provided that the following conditions are met: 

• Redistributions of source code must retain the above copyright notice, this list of conditions and 
the following disclaimer. 

• Redistributions in binary form must reproduce the above copyright notice, this list of conditions 
and the following disclaimer in the documentation and/or other materials provided with the 
distribution. 

• The end-user documentation included with the redistribution, if any, must include the following 
acknowledgment: "This product includes software developed by the Apache Software 
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Foundation (http://www.apache.org/)." Alternately, this acknowledgment may appear in the 
software itself, if and wherever such third-party acknowledgments normally appear. 

• The names "Xerces" and "Apache Software Foundation" must not be used to endorse or 
promote products derived from this software without prior written permission. For written 
permission, please contact apache@apache.org. 

• Products derived from this software may not be called "Apache", nor may "Apache" appear in 
their name, without prior written permission of the Apache Software Foundation. 

 

THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, 
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE APACHE SOFTWARE 
FOUNDATION OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF 
THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

 

This product includes software developed by the Apache Software Foundation 
(http://www.apache.org/) and Info-Zip (http://www.info-zip.org/pub/INFO-ZIP/). 

This software consists of voluntary contributions made by many individuals on behalf of the Apache 
Software Foundation and was originally based on software copyright (c) 1999, International Business 
Machines, Inc., http://www.ibm.com.  For more information on the Apache Software Foundation, 
please see <http://www.apache.org/>. 

SAP and/or its distributors may offer, and charge a fee for, warranty, support, indemnity or liability 
obligations to one or more recipients of the software. However, SAP and/or its distributors may do so 
only on its/their own behalf, and not on behalf of the Apache Software Foundation or its contributors. 

UNZIP. This is version 2003-May-08 of the Info-ZIP copyright and license. The definitive version of 
this document should be available at ftp://ftp.info-zip.org/pub/infozip/license.html indefinitely.  

Copyright (c) 1990-2003 Info-ZIP. All rights reserved. 

For the purposes of this copyright and license, "Info-ZIP" is defined as the following set of individuals: 

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter 
Goatley, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, 
Paul Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. 
Miller, Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve 
Salisbury, Dave Smith, Christian Spieler, Antoine Verheijen, Paul von Behren, Rich Wales, Mike 
White  

This software is provided "as is," without warranty of any kind, express or implied. In no event shall 
Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential 
damages arising out of the use of or inability to use this software.  

Permission is granted to anyone to use this software for any purpose, including commercial 
applications, and to alter it and redistribute it freely, subject to the following restrictions:  

Redistributions of source code must retain the above copyright notice, definition, disclaimer, and this 
list of conditions.  

Redistributions in binary form (compiled executables) must reproduce the above copyright notice, 
definition, disclaimer, and this list of conditions in documentation and/or other materials provided with 
the distribution. The sole exception to this condition is redistribution of a standard UnZipSFX binary 
(including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of this 
license, as long as the normal SFX banner has not been removed from the binary or disabled.  

Altered versions--including, but not limited to, ports to new operating systems, existing ports with new 
graphical interfaces, and dynamic, shared, or static library versions--must be plainly marked as such 
and must not be misrepresented as being the original source. Such altered versions also must not be 
misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the altered 
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versions with the names "Info-ZIP" (or any variation thereof, including, but not limited to, different 
capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the explicit permission of Info-ZIP. Such 
altered versions are further prohibited from misrepresentative use of the Zip-Bugs or Info-ZIP e-mail 
addresses or of the Info-ZIP URL(s). 

Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip," "UnZipSFX," "WiZ," "Pocket 
UnZip," "Pocket Zip," and "MacZip" for its own source and binary releases.  

MarketSet and Enterprise Buyer are jointly owned trademarks of SAP AG and Commerce One.  

SAP, SAP Logo, R/2, R/3, mySAP, mySAP.com, and other SAP products and services mentioned 
herein as well as their respective logos are trademarks or registered trademarks of SAP AG in 
Germany and in several other countries all over the world.  All other product and service names 
mentioned are the trademarks of their respective companies. 

Copyright and Licensing Information for ACE(TM) and TAO(TM) 

ACE(TM) and TAO(TM) are copyrighted by Douglas C. Schmidt and his research group at 
Washington University, University of California, Irvine, and Vanderbilt University Copyright (c) 1993-
2003, all rights reserved. Since ACE+TAO are open-source, free software, you are free to use, 
modify, copy, and distribute--perpetually and irrevocably--the ACE+TAO source code and object 
code produced from the source, as well as copy and distribute modified versions of this software. 
You must, however, include this copyright statement along with code built using ACE+TAO.  

You can use ACE+TAO in proprietary software and are under no obligation to redistribute any of 
your source code that is built using ACE+TAO. Note, however, that you may not do anything to the 
ACE+TAO code, such as copyrighting it yourself or claiming authorship of the ACE+TAO code that 
will prevent ACE+ TAO from being distributed freely using an open-source development model. You 
needn't inform anyone that you're using ACE+TAO in your software, though we encourage you to let 
us know so we can promote your project in the ACE+TAO success stories..  

ACE+TAO are provided as is with no warranties of any kind, including the warranties of design, 
merchantability, and fitness for a particular purpose, noninfringement, or arising from a course of 
dealing, usage or trade practice. Moreover, ACE+TAO are provided with no support and without any 
obligation on the part of Washington University, UC Irvine, Vanderbilt University, their employees, or 
students to assist in its use, correction, modification, or enhancement. However, commercial support 
for ACE is available from Riverace and commercial support for TAO is available from OCI and 
PrismTech. Both ACE and TAO are Y2K-compliant, as long as the underlying OS platform is Y2K-
compliant.  

Washington University, UC Irvine, Vanderbilt University, their employees, and students shall have no 
liability with respect to the infringement of copyrights, trade secrets or any patents by ACE+TAO or 
any part thereof. Moreover, in no event will Washington University, UC Irvine, or Vanderbilt 
University, their employees, or students be liable for any lost revenue or profits or other special, 
indirect and consequential damages.  

The ACE and TAO web sites are maintained by the Center for Distributed Object Computing of 
Washington University for the development of open-source software as part of the open-source 
software community. By submitting comments, suggestions, code, code snippets, techniques 
(including that of usage), and algorithms, submitters acknowledge that they have the right to do so, 
that any such submissions are given freely and unreservedly, and that they waive any claims to 
copyright or ownership. In addition, submitters acknowledge that any such submission might become 
part of the copyright maintained on the overall body of code, which comprises the ACE and TAO 
software. By making a submission, submitter agrees to these terms. Furthermore, submitters 
acknowledge that the incorporation or modification of such submissions is entirely at the discretion of 
the moderators of the open-source ACE+TAO projects or their designees.  

The names ACE(TM), TAO(TM), Washington University, UC Irvine, and Vanderbilt University, may 
not be used to endorse or promote products or services derived from this source without express 
written permission from Washington University, UC Irvine, or Vanderbilt University. Further, products 
or services derived from this source may not be called ACE(TM) or TAO(TM), nor may the name 
Washington University, UC Irvine, or Vanderbilt University appear in their names, without express 
written permission from Washington University, UC Irvine, and Vanderbilt University. 

SAP Library document classification: PUBLIC 
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